如何在Intellij 15降级Kotlin

对于我的项目,我需要使用Kotlin 1.0.0-1038(测试版),但要安装它,我可能需要卸载较新版本的kotlin,但它没有卸载按钮,它应该有。

我将如何降级Kotlin? IntelliJ IDEA 15.0.4

One Solution collect form web for “如何在Intellij 15降级Kotlin”

重要的UPD:作为@yole评论,这是一个不好的解决方案,因为它会打破的事情。 在没有破坏安装的情况下,没有合适的方法来降级捆绑的插件。 相反,请考虑将项目升级到最新的Kotlin版本。

你有与IntelliJ IDEA捆绑在一起的插件。 您自担风险 ,可以从IntelliJ IDEA安装( plugins/kotlin子文件夹)中手动删除文件夹。 之后,您将能够从zip发行版中安装任何兼容的插件版本,但IDEA 安装将被破坏 (请参阅评论)。

  • 更新到kotlin 1.0.0-beta后,Kotlin cli应用程序无法正常工作
  • Kotlin / Android应用程序 - 从外部活动更改视图元素
  • 在Kotlin中不能返回tailrec函数的阶乘结果
  • 我无法在Android中的类中初始化我的数组(MutableList)
  • 在Kotlin中的types转换错误:ArrayList
  • Kotlin将hex字符串解析为长
  • 使用IntelliJ IDEA构建Gradle多模块的正确结构
  • Android - 在Kotlin中声明和使用视图
  • 任何人都可以告诉我kotlin编译器是如何工作的? 它的架构是什么?
  • 伴侣对象块和kotlin类外的趣味之间的区别?
  • 为什么在Kotlin中val box1和val box2都是正确的?
  • Kotlin language will be the best programming language for Android.