Android中的Realm 0.87.5

我已经更新Realm 0.87.5,现在我得到构建这个错误。 你能帮我一下吗?

Error:Execution failed for task ':app:transformNativeLibsWithMergeJniLibsForDebug'. > com.android.build.api.transform.TransformException: com.android.builder.packaging.DuplicateFileException: Duplicate files copied in APK lib/x86/librealm-jni.so File1: /Users/[USER_NAME]/.gradle/caches/modules-2/files-2.1/io.realm/realm-android/0.87.5/ab4e1fead1380252dad0e95658e53ea0c113e89c/realm-android-0.87.5.jar File2: /Users/[USER_NAME]/.android/build-cache/97d752c34cee76117e22adcee3a9c2d132f80273/output/jni 

根源依赖:

根相关性

应用模块相关性:

应用程序模块依赖关系

3 Solutions collect form web for “Android中的Realm 0.87.5”

将其添加到项目级别的gradle文件中

 classpath "io.realm:realm-gradle-plugin:4.3.3" 

在你的模块级别的gradle文件中做这个

  apply plugin: 'kotlin-kapt' // if using kotlin apply plugin: 'realm-android' 

但更重要的是,如果您尝试使用比0.88.0更新的版本(例如4.3.3),请确保您的模块级别依赖关系中没有像0.87.5这样的过时版本。

  dependencies { // compile "io.realm:realm-android:0.87.5" <-- make sure you don't have that 

那么你可能需要清理+重建。

试试:

 classpath "io.realm:realm-gradle-plugin:3.6.0-SNAPSHOT" 

在你的gradle项目依赖项中

并检查你是否使用:

 apply plugin: 'realm-android' 

在您的模块应用程序文件

简单地说,你不必为Realm DB编译任何依赖,你只需要添加两行,

在应用程序级别的Gradle文件中

 apply plugin: 'realm-android' 

在项目级别的Gradle文件中

 dependencies { classpath "io.realm:realm-gradle-plugin:3.5.0" } 
Kotlin language will be the best programming language for Android.