Android工作室插件ID:’kotlin-android-extensions’

我正在使用gradle,并且正在尝试将kotlin添加到我的项目中。 但是当我试图为gradle添加“kotlin-android-extensions”插件时,它无法find它。

2 Solutions collect form web for “Android工作室插件ID:’kotlin-android-extensions’”

要使用插件,您必须将其添加到根级别文件中:

buildscript { repositories { jcenter() maven { url 'https://maven.google.com' } } ext.kotlin_version = '1.1.2-4' dependencies { classpath "org.jetbrains.kotlin:kotlin-gradle-plugin:$kotlin_version" } } 

尝试将以下内容添加到您的gradle.build文件

 apply plugin: 'kotlin-android' apply plugin: 'kotlin-android-extensions' 

之后,你必须在你的依赖关系类路径中进行一些更改。

 buildscript { ext.kotlin_version = '1.1.60' repositories { jcenter() } dependencies { classpath 'com.android.tools.build:gradle:2.1.0' classpath "org.jetbrains.kotlin:kotlin-gradle-plugin:$kotlin_version" // NOTE: Do not place your application dependencies here; they belong // in the individual module build.gradle files } } 

并在依赖关系编译确保添加jre7这样的。

 compile "org.jetbrains.kotlin:kotlin-stdlib-jre7:$kotlin_version" 

完成所有重建Gradle后,你就完成了。 这对我来说是有效的,因为我现在面临着同样的问题,之后就完成了。 希望它适合你…

  • com.android.builder.dexing.DexArchiveMergerException:无法在运行时合并dexexception
  • Android - 将资产复制到内部存储
  • 安卓Braintree,贝宝不工作
  • Android Studio 3.0.1(错误:'java'插件已被应用,但与Android插件不兼容。)
  • kotlin是function性的还是程序性的?
  • 如何从kotlin的道路上获得歌曲的ALBUM ART?
  • 编写JS和Java的代码
  • 如何从Kotlin代码动态设置权重属性?
  • 在kotlin中使用意外的令牌(在同一行上使用;来分隔expression式)
  • Android注释与Kotlin和生成工具2.3.0
  • 无法创建新用户
  • Kotlin language will be the best programming language for Android.