Android Studio中过时的Kotlin运行时警告

下载并安装最新的Kotlin插件后,我有Android Studio的Kotlin Runtime警告,告诉我:

kotlin-stdlib-1.1.2”库中的Kotlin运行时版本是1.1.2,而插件版本是1.1.2-release-Studio2.3-3。 运行时库应该更新以避免兼容性问题。

我试图点击更新运行时按钮,但得到另一个消息:

Gradle项目的自动库版本更新当前不受支持。 请手动更新您的build.gradle。

如何解决这个问题?

6 Solutions collect form web for “Android Studio中过时的Kotlin运行时警告”

您可以在您的项目级别build.gradle文件中更新您的Kotlin版本。 如果您按照惯例配置了它,则应该在顶部附近有以下行:

 ext.kotlin_version = '1.1.2' 

要升级到与您的插件匹配的版本,只需将此行更改为:

 ext.kotlin_version = '1.1.2-3' 

编辑 (回答下面的问题):

错误告诉你,你需要升级你的版本,问题是在哪里发现你必须把1.1.2-3而不是说,例如1.1.2-release-Studio2.3-3

如果版本号不是这样的,那么最好的办法是检查托管版本的版本库。 在Android的情况下,你可能会从jcenter获得它,你可以find存储库页面 ,其中列出了所有可用的版本。

你也可以浏览jcenter的原始maven仓库,通过在这里进行实际的托管,或者在mvnrepository或者mavencentral (后者的原始版本)上查找Kotlin。

在你的项目build.gradle文件中find这个: ext.kotlin_version = 'xxx' ,用当前版本的Kotlin插件更改xxx。 在这里输入图像说明

为了检查哪个是Kotlin插件的当前版本:

  1. 转到:工具 – > Kotlin – > Confugure Kotlin插件更新

  2. 点击“立即检查更新”。 一秒钟后,你会看到你的Kotlin插件的版本。 (如果不是最新的,你的Kotlin插件将被更新。) 在这里输入图像说明 在这里输入图像说明

它抱怨(在Android Studio 3.0.1)…最有可能是因为引用库的依赖关系:

‘org.jetbrains.kotlin:kotlin-stdlib:1.1.3@jar’库中的Kotlin运行时版本是1.1.3,而插件版本是1.1.51-release-Studio3.0-1。

那么我已经强制建立它所需的版本,在模块级build.gradle

 configurations.all() { resolutionStrategy.force 'org.jetbrains.kotlin:kotlin-stdlib:1.1.51' } 

结果是:

 ./gradlew app:dependencies | grep kotlin Download https://jcenter.bintray.com/org/jetbrains/kotlin/kotlin-stdlib/1.1.51/kotlin-stdlib-1.1.51.pom | | +--- org.jetbrains.kotlin:kotlin-stdlib:1.1.3 -> 1.1.51 ... 

将您的ext.kotlin_version从“1.1.2-4”更改为ext.kotlin_version =’1.1.2-5’为我解决了这个问题

当你更新从android studiopopup的kotlin插件版本时,会出现这个问题,但问题是Android studio的当前版本不能动态更改位于项目级别Build.gradle文件中的kotlin gradle插件。

 dependencies { classpath "org.jetbrains.kotlin:kotlin-gradle-plugin:1.2.10" } 

如何解决这个问题?

所以你需要手动改变这个版本,你可以在这里find

我曾经在Canary频道的最新Android Studio上遇到这个问题。 您也可以考虑将Android Studio降级到稳定版本。

这发生在Android Studio 3.0 RC1上。

  • 如何显示从Android库反编译的Kotlin代码
  • 在Android Studio中将“java”目录重命名为“kotlin”
  • 从字符串拆分空间不工作在Kotlin
  • Kotlin Android应用程序编译失败,消息:未解决的参考:kotlinx
  • 选项+进入快速修复不工作在最新的Android工作室
  • 在kotlin中生成方法或类注释
  • 如何用JSON API支架列表制作KOTLIN列表
  • 用于将方法参数分配给Android Studio中的字段的Kotlin快捷方式
  • 各种问题@NonNull,@NotNull和@ParametersAreNonnullByDefault
  • Android Studio转换为Kotlin:在某些情况下使用@JvmStatic
  • IDE在android studio 3.0.1中创建一个新的活动时出错
  • Kotlin language will be the best programming language for Android.