IDE在android studio 3.0.1中创建一个新的活动时出错

我有问题,以创建新的活动在Android Studio 3.0.1的Windows 10,问题是,直到昨天一切工作,但现在它会引发错误,当试图创建一个新的活动,然后,不要创建它。

只能创建类或空的活动,但没有其他出现在画廊。

错误消息是:

SingleRootFileViewProvider中的文件树不一致(myVirtualFile = LightVirtualFile:\ targetFile,content = VirtualFileContent {size = 69}}; nodeLength = 137; 文件长度= 69

第一个错误窗口

第二个错误窗口

我已经完成了所有工作,我已经下载了最新版本的Gradle,并且重新安装了Android Studio。

3 Solutions collect form web for “IDE在android studio 3.0.1中创建一个新的活动时出错”

这是一个已知的错误 : https : //youtrack.jetbrains.com/issue/KT-22349

问题:从Gallery中创建Android Studio中的新活动

Android Studio:Android Studio 3.0.1。 (MacOS和Windows)

最近更新:我最近更新到Kotlin插件Version: 1.2.20-release-Studio3.0-1的最新更新。

解决方案,为我工作:我关闭了Android Studio中的Kotlin插件 – >插件 – > Kotlin,并重新启动Android Studio。 问题没有了。

再次打开Koltin插件,问题又回来了。

更新:在最新的更新v-1.2.21解决了这个问题 – 如果在插件下没有在Android Studio中看到它,请直接从网站下载: https : //plugins.jetbrains.com/plugin/6954-kotlin

编辑(27/01/2018) :这个问题已被Jetbrains修复。 只需更新您的Kotlin插件。


正如@Sharj所说,这是一个已知的错误 。

第一个解决方案是禁用Kotlin插件: 文件 > 设置 > 插件和unckeck Kotlin

但是,如果您需要使用插件,则必须将其降级到版本1.2.10

为此,请下载对应于您的Android Studio版本的Jetbrain Plugin Repository上的1.2.10插件归档文件。 对我来说是1.2.10-release-Studio3.0-1

然后安装它: 文件 > 设置 > 插件,然后选择从磁盘安装插件...。 选择刚刚下载的1.2.10-release-Studio3.0-1.zip压缩包,然后重新启动Android Studio。

最新版本的插件(1.2.21-release-Studio3.01-1)解决了这个问题。

  • Kotlin auto在Android Studio中完成覆盖
  • “包含Kotlin支持”checkbox不在Android Studio 3.0 Canary 5中
  • 如何使用DataSource作为数据库和网络来实现页面库?
  • Kotlin和Android Studio非法状态exception
  • 在Android工作室Kotlin
  • Kotlin文件不能使用R.java
  • 使用意向操作在Android Studio中创建Kotlin类
  • 运行unit testing没有发现变化
  • 选项+进入快速修复不工作在最新的Android工作室
  • Android Studio和Kotlin:未解决的参考:也
  • Android Studio 3.0 - 无法find方法'com.android.build.gradle.internal.variant.BaseVariantData.getOutputs()Ljava / util / List'
  • Kotlin language will be the best programming language for Android.