Kotlin错误:无法findorg.jetbrains.kotlin:kotlin-stdlib-jre7:1.0.7

我将Kotlin插件安装到我的应用程序中(v1.1.1-release-Studio2.2-1),然后选择“在项目中配置Kotlin”我选择了编译器和运行时版本1.0.7。 Kotlin更新了我的Gradle文件。 现在,当我尝试建立我得到:

错误:配置项目“:app”时发生问题。 无法解析配置的所有依赖关系:“app:_debugApkCopy”。 找不到org.jetbrains.kotlin:kotlin-stdlib-jre7:1.0.7。 要求:

所有MyApplication:应用程序:未指定

我不知道我在这里错过了什么。

5 Solutions collect form web for “Kotlin错误:无法findorg.jetbrains.kotlin:kotlin-stdlib-jre7:1.0.7”

在项目级别gradle只使用这个版本

ext.kotlin_version =’1.1.1′

删除其他版本

kotlin-stdlib分割为kotlin-stdlib-jre7kotlin-stdlib-jre8只能在Kotlin 1.1中引入,这就是为什么依赖不能被解析,软件包版本根本不存在。

它看起来像你的项目文件的更新失败,并将Kotlin版本设置为1.0.7。 如果这是一个新的项目,并且没有什么能够阻止你使用1.1.1,那么我会切换到这个项目。 这样做后,你的问题应该消失。

在“build.gradle”文件中,更改当前Kotlin版本的行并按下synk:

 ext.kotlin_version = '1.1.1' 

///看起来像这样:

//顶级构建文件,您可以在其中添加所有子项目/模块通用的配置选项。

 buildscript { ext.kotlin_version = '1.1.1' repositories { jcenter() } dependencies { classpath 'com.android.tools.build:gradle:2.3.0' classpath "org.jetbrains.kotlin:kotlin-gradle-plugin:$kotlin_version" // NOTE: Do not place your application dependencies here; they belong // in the individual module build.gradle files } } 
  1. 请在下面的路径中检查您的Kotlin的当前版本,

    C:\ Program Files \ Android \ Android Studio \ gradle \ m2repository \ org \ jetbrains \ kotlin \ kotlin-stdlib \ 1.0.5

在项目级gradle文件中更改为该版本(1.0.5)

你可以在上面的路径中看到没有提到任何Java- jre version ,所以在你的应用级别的gradle文件中删除如下,

 compile "org.jetbrains.kotlin:kotlin-stdlib:$kotlin_version" 

https://stackoverflow.com/a/44148210/8056898

根据系统中的当前版本更改Kotlin版本。

  • Android w / Kotlin纯java-Junit的NoClassDefFoundError解决方法不起作用
  • 在JOOQ中,如果我直接使用底层连接,是否保持我的事务状态?
  • Kotlin在编译时未解决的参考
  • Maven with Kotlin 1.2:一个需要的类缺少kotlin / reflect / KDeclarationContainer
  • 在Kotlin中禁用查看Viewrger的View Pagerwipe
  • 如何在Kotlin中指定duck typing(隐式接口)generics?
  • 用匕首使用Kotlin
  • 集团捕捉
  • 是否有必要知道kotlin获得AAD(Associate Android Developer)认证?
  • 调用(基本)委托function时,从内部使用类委托覆盖
  • forEach里面forEach在Kotlin
  • Kotlin language will be the best programming language for Android.