房间Kotlin:实体和Pojos必须有一个可用的公共构造函数

当我运行我的应用程序时,我得到了跟进错误。

Error: Entities and Pojos must have a usable public constructor. You can have an empty constructor or a constructor whose parameters match the fields (by name and type). Tried the following constructors but they failed to match: ChatMsg(java.lang.String,int) : [arg0 : null, arg1 : null] Error: Entities and Pojos must have a usable public constructor. You can have an empty constructor or a constructor whose parameters match the fields (by name and type). Error: Entities and Pojos must have a usable public constructor. You can have an empty constructor or a constructor whose parameters match the fields (by name and type). Tried the following constructors but they failed to match: ChatMsg(java.lang.String,int) : [arg0 : null, arg1 : null] Error: Entities and Pojos must have a usable public constructor. You can have an empty constructor or a constructor whose parameters match the fields (by name and type). Warning: Schema export directory is not provided to the annotation processor so we cannot export the schema. You can either provide `room.schemaLocation` annotation processor argument OR set exportSchema to false. 

这是我的项目build.gradle

 buildscript { ext.kotlin_version = '1.1.2-4' repositories { maven { url 'https://maven.google.com' } jcenter() } dependencies { classpath 'com.android.tools.build:gradle:3.0.0-alpha4' classpath "org.jetbrains.kotlin:kotlin-gradle-plugin:$kotlin_version" classpath 'com.letv.sarrsdesktop:BlockCanaryExPlugin:0.9.9.2' } } allprojects { repositories { jcenter() maven { url 'https://maven.google.com' } maven { url "https://jitpack.io" } mavenCentral() } } task clean(type: Delete) { delete rootProject.buildDir } 

这是我的build.gradle模块

 apply plugin: 'com.android.application' apply plugin: 'kotlin-android' kapt { generateStubs = true } android { compileSdkVersion 25 buildToolsVersion "25.0.2" defaultConfig { applicationId "cn.sz.cyrus.kotlintest" minSdkVersion 14 targetSdkVersion 25 versionCode 1 versionName "1.0" testInstrumentationRunner "android.support.test.runner.AndroidJUnitRunner" javaCompileOptions{ annotationProcessorOptions{ includeCompileClasspath = true } } } buildTypes { release { minifyEnabled false proguardFiles getDefaultProguardFile('proguard-android.txt'), 'proguard-rules.pro' } } } dependencies { compile fileTree(include: ['*.jar'], dir: 'libs') androidTestCompile('com.android.support.test.espresso:espresso-core:2.2.2', { exclude group: 'com.android.support', module: 'support-annotations' }) compile "org.jetbrains.kotlin:kotlin-stdlib-jre7:$kotlin_version" compile "org.jetbrains.kotlin:kotlin-reflect:$kotlin_version" compile 'com.android.support:appcompat-v7:25.3.1' testCompile 'junit:junit:4.12' compile 'com.android.support:design:25.3.1' compile 'com.android.support.constraint:constraint-layout:1.0.2' debugCompile 'com.squareup.leakcanary:leakcanary-android:1.5.1' releaseCompile 'com.squareup.leakcanary:leakcanary-android-no-op:1.5.1' testCompile 'com.squareup.leakcanary:leakcanary-android-no-op:1.5.1' compile 'com.github.GrenderG:Toasty:1.2.5' compile 'com.orhanobut:logger:1.15' compile 'io.reactivex.rxjava2:rxandroid:2.0.1' compile 'com.umeng.analytics:analytics:latest.integration' compile 'com.github.kittinunf.fuel:fuel-android:1.7.0' //for Android compile 'com.github.kittinunf.fuel:fuel-rxjava:1.7.0' //for RxJava support compile "android.arch.persistence.room:runtime:1.0.0-alpha3" annotationProcessor "android.arch.persistence.room:compiler:1.0.0-alpha3" kapt "android.arch.persistence.room:compiler:1.0.0-alpha3" compile "android.arch.persistence.room:rxjava2:1.0.0-alpha3" } 

这是我的pojo类

 @Entity data class ChatMsg(var msg: String, var to: Int) { companion object TO { val MASTER = 0 val ROBOT = 1 } @PrimaryKey(autoGenerate = true) var id: Int = 0 var createTime: Long = System.currentTimeMillis() var translMsg: String = "" } 

我有谷歌我的问题,但结果似乎无法回答我的问题。谁有这个问题的想法。 感谢您的第一!

One Solution collect form web for “房间Kotlin:实体和Pojos必须有一个可用的公共构造函数”

错误消息确切地说:

你可以有一个空的构造函数或者一个构造函数,它们的参数匹配字段(按名称和类型 )。

有一点要注意。 你应该使用Annotation Site Target将@PrimaryKey放到正确的位置。

所以你的实体应该有一个空的构造函数:

 @Entity data class ChatMsg(var msg: String, var to: Int) { constructor() : this("", UNKNOWN); companion object TO { val MASTER = 0 val ROBOT = 1 private val UNKNOWN = -1; // just use for initializing } @field: PrimaryKey(autoGenerate = true) var id: Int = 0 } 

或者应该有一个匹配字段的构造函数。

 @Entity data class ChatMsg( @field:PrimaryKey(autoGenerate = true) var id: Int, var createTime: Long = System.currentTimeMillis(), var translMsg: String = "", var msg: String, var to: Int ) { companion object TO { val MASTER = 0 val ROBOT = 1 } } 
  • 与Proguard和Kotlin“找不到引用类”
  • Kotlin:Java利用日期到数据绑定的字符串
  • Kotlin - 如何为RecyclerVIew实现ItemClickListener
  • 设置一个字段的值,而不用调用set方法 - Kotlin
  • Kotlin - 对伴侣对象的属性可见性
  • Kotlin:迭代一个具有解构条目的地图是不是可能的? 错误?
  • 用消息“此处不允许的方法”来改写响应代码405
  • Intellij IDEA中Kotlin项目的自动完成和代码分析非常慢
  • Kotlin JPA封装OneToMany
  • 为什么不安全的.run()调用在Kotlin的空值上工作正常?
  • 在Idea中Kotlin脚本文件的语法高亮
  • Kotlin language will be the best programming language for Android.