我可以对来自Java API的平台类型执行无效安全吗?

从Kotlin版本M9中删除了“强制平台类型的无效安全”。

https://blog.jetbrains.com/kotlin/2014/10/making-platform-interop-even-smoother/

但是,我想要使所有的Java API可以为空,除非指定为@NotNull ,这样!!?. 应该再次明确。

在当前版本的IntelliJ IDEA中可以吗?

它部分来自最近的Kotlin版本@ParametersAreNonnullByDefault

https://youtrack.jetbrains.com/issue/KT-10942